Forum Upgrade

  • So sieht die Seite auf verschiedenen Browsern aus: http://browsershots.org/https://www.ttlg.de/

    Würde mich auch interessieren welchen Browser du nutzt @ zappenduster - vielleicht läuft es ja mit einem anderen deutlich besser.

    Hardwaredaten? Hab hier nur sehr geringe Auslastung auf dieser Seite. Altes Windows? XP? 3.11?

    Darf man fragen welche bestimmten Gründe das sind mit der "älteren Hardware"? :)


    Mir würde es freuen wenn du uns hier noch erhalten bleibst, sonst wird es so "zappenduster" :D

  • Neues Forum, neue Features.

    Ich habe ein Problem, nachträglich Posts zu editieren ("bearbeiten"). Und zwar geht es um eingefügte Links. Ich sehe sie nicht im Bearbeitungsfenster.

    Braucht man dazu bestimmte Einstellungen?


    "Black Swan" sieht übrigens schon viel funktioneller aus ;)

  • Ich habe es eben selber nochmal probiert. Im Bearbeitungsfenster markierst du den Link, klickst auf die Schaltfläche für Link bearbeiten (die Kette) und im erscheinenden Menü auf "Link bearbeiten". Oder meintest du was anderes?

  • Auweia, jetzt sehe ich auch die Problematik. Scheinbar wurde im Zuge des Forum-Upgrades einige Links zerschossen. Scheint aber zum Glück nicht alle Posts zu betreffen. Die gute Nachricht ist, dass du die Links auch manuell im HTML-Quellcode ändern kannst, dazu einfach auf den ersten Button gleich links in der Bearbeitungsleiste klicken.


    Ich hab mal die ersten Links für dich korrigiert, damit du ein Beispiel hast, wie du es fixen kannst. Falls es immer noch Probleme gibt, gib einfach Bescheid.

  • Ich vermute, es hängt davon ab, ob es Links mit Bezeichner sind (wie im DromEd-Skript-Thread). Diese wurden korrekt übernommen, aber bei Links ohne Bezeichner (siehe Contests) ist wohl irgendwie das System durcheinander gekommen.

  • Ein Tip bezüglich der übergrossen Schriften und Logos, welche das Forum sehr unübersichtlich machen :

    im Firefox z.B. kann man unter 'Ansicht/Zoom' einfach 3 bis 4 mal herauszoomen.

    Zumindest bei mir merkt er sich das beim nächsten Start für diese Seite.

    Dann sieht das ungefähr wieder so übersichtlich aus wie im alten Forum.

  • Ich finde die Schriftgröße in meinem Browser (Firefox) eigentlich ganz okay. Wenn ich herauszoome, wird die Schrift so klein, dass ich kaum etwas lesen kann. Trotzdem habe ich nur 1 - 2 Posts auf meinem Bildschirm, was wohl an den riesengroßen Textboxen / Profilbildern liegt. Vielleicht kann man ja die Textboxen insgesamt etwas kleiner machen, die scheinen mir (insbesondere wenn wenig Text drin steht) ziemlich überdimensioniert.

    Außerdem finde ich den Kontrast beim Schreiben (weiße Schrift auf hellgrauem Hintergrund) ungünstig. Das erschwert z.T. flüssiges (Nach-)Lesen beim Schreiben, weiß nicht, ob es nur mir so geht.

    Ansonsten finde ich die Neuerungen insgesamt gelungen. Der größter Vorteil im Vergleich zu vorher ist meiner Meinung nach das Lesen mit dem Smartphone, was ich nun auch häufiger nutzen werde. Performance-Probleme hatte ich nach der Umstellung übrigens keine. Auch beim Handling habe ich mich schnell reingefuchst. Es geht schon irgendwie, wenn man nur will..

  • Wie schon angesprochen kannst du einen anderen Stil wählen, dann kannst du besser lesen.


    Ich stelle gerade fest, es hier einige böse Tracker gibt. "Moderne" Forensoftware halt.

    Die Tracker werden bei mir mit umatrix/Privacy Badger schon rausgefischt

    blockt also

    -ajax.googleapis.com

    -fonts.googleapis.com

    Ich fände es gut, diese "Social Schrottworks"-Teilen Buttons generell auszublenden/zu deaktivieren. Man muß ein Zeichen setzen und wenns nur ein Kleines ist.

  • Diese Social-Buttons fand ich schon immer unnütz, ich hatte nur die ganze Zeit irgendwie nicht darauf geachtet. Zum Glück lassen die sich einfach deaktivieren. Selbiges gilt für das Like-System. Irgendwie kopieren alle wohl von Facebook? 8o

  • Ist es möglich neue ungelesene Themen, wie im alten Forum, fett oder ähnlich hervorzuheben?

    Man hat dann einen schnelleren Überblick.


    Ich erinner mich, daß es auch einen Link/Eintrag gab zu ttlg.de/others/thiefworld .

    Ist das gestorben, oder braucht es noch etwas Zeit ?

  • Es ist schon viele jahre her, als ich in der History von ttlg.de gelesen habe, daß sie mit Thiefworld zusammengelegt wurde. Mich hat interessiert wie die Seite aussah und bin nach kurzem Suchen auf diesen Link gestoßen. Die Seite endet anscheinend mit dem Zeitpunkt des Zusammenschlusses.

  • Nunja, auch ich muss jetzt mal ein kleines Feedback zum neuen Forum-Outfit geben, da ich ja doch ab und an mal vorbei schaue. Das meiste und wichtigste wurde ja schon gesagt. Aber auch mich stört immens dieser riesige, weil unnötige, Stil der geposteten Beiträge. Wenn ich hier sehe, dass für ganze zwei Wörter der Platz einer halben Seite draufgeht. Finde auch ich ein No-Go. Das Forum verliert dadurch sehr an Übersichtlichkeit, fand ich vorher besser. Das ist dieser allseits beliebte und übernommene Stil des großen Kastens, in dem aber nichts drin steht. Das ist für mich eindeutig Platzverschwendung. Und ja, natürlich kann ich aus der Seite rauszoomen - ist aber nicht im Sinne des Erfinders und dadurch wird die gesamte Seite kleiner, hab ich auch nichts davon. Also bitte, auch ich wäre euch dankbar, wenn ihr die Seite wieder kleiner und übersichtlicher gestalten könntet. Zappenduster hat Recht damit, die meisten kommen hier nur schnell wegen ein paar Infos vorbei, und nun ist alles so unübersichtlich. Ich war beim allerersten Anblick sehr erschrocken. Aber mit 2 Posts den ganzen Bildschirm füllen, nein danke. Da bin ich nur noch mit Scrollen beschäftigt. Es wäre sicherlich kein großer Akt, das Profilbild und die Infos zum User etwas kleiner zu gestalten, damit die Fläche daneben ebenfalls kleiner wird. Oder die Infos in eben diese Fläche integrieren, wie es vorher der Fall war. Weil, ich bin hier ja nicht bei Whatsapp. ;)


    Über das Handy ist die Seite natürlich super, aber man kann sich nicht immer nur an der Nutzbarkeit über Handys orientieren. Dann soll es eine Version für Smartphones und eine für Browser am PC geben. Mittlerweile wird so oft für Handys optimiert und der Nutzer am heimischen PC hat dann das Nachsehen, weil es dann so aussieht wie es hier aussieht. (Ist so wie bei Spielen, die für die PlayStation entwickelt werden, und es dann nur eine mit Kompromissen optimierte Version für Windows für das Spielen mit Maus und Tastatur gibt, erfreut sich auch keiner großen Beliebtheit.) Ja, es ist moderner und schicker. Aber ttlg.com finde ich da trotz der sehr nüchternen Aufmachung trotzdem 10 Mal besser, weil ich eine gute Übersicht habe. Und darum geht es in Foren. Das Hintergrundbild ist zwar schick hier, aber zum rechten Rand hin tendierend stört es beim Lesen, da es heller wird. (Und ja, den dunklen Stil habe ich schon ausprobiert, finde ich aber furchtbar, weil man nach einer halben Minute nur noch Streifen sieht durch helle Schrift auf dunklem Grund. Das ist anstrengend.)


    Mit dem Einloggen hatte ich keine Probleme. Gut finde ich, dass hervorgehoben wird, welche Beiträge neu sind. Das fällt durch die roten Kreise besser ins Auge.

    Performanceprobleme habe ich keine. Bin aber auch nicht mit Uralt-Technik unterwegs. :D


    Ich weiß allerdings leider nicht, warum mittlerweile so viele diesem platzfressenden, unnötigen, "modernen" Stil folgen müssen. Ich komme mir teilweise vor wie ein Kleinkind, das große, bunte Schaltflächen braucht, weil es nicht lesen kann. Bitte, liebe Leute, ich weiß, ihr gebt euch viel Mühe. Aber ich plädiere für Übersichtlichkeit.

  • Ich stelle gerade fest, dass alle Links , die Crawler über die Jahre gelistet haben, nicht mehr funktionieren (also tausende Links, die nicht mehr gehen). Denn das Forum hatte früher die Adresse


    http(s)://board.ttlg.de/


    Nun heißt die aber

    https://www.ttlg.de


    Könnte man das umleiten, so dass man direkt ans Ziel kommt, anstelle zum Dashboard?

  • Hallo,


    ich hab gedacht in letzter Zeit gab es keine neuen Beiträge.

    Warum? Sieht man an den 3 Screenshots von der Menüleiste.

    Beim ersten Bild: So sah ich es, dachte mir wieder, es gibt schon wieder nichts neues. Doch dann hab ich gesehen dass man die Menüleiste nach rechts scrollen kann, zum Vorschein kam eine 6 (auf Bild 2 ist es eine 3, da ich schon 3 Beiträge angeschaut hatte)

    Nachdem ich alles angeschaut hatte war die Menüleiste wieder ein Stückchen kleiner(Bild 3) und somit nicht mehr Scrollbar.


    Mein Vorschlag wäre die Abstände zwischen den Menüs zu verkleinern damit man ohne zu scrollen sieht wenn es neue Beiträge gibt.

    Auflösung: 1920x1080 (FullHD)

  • Ich habe mit dem jetzt nicht mehr ganz so neuen Erscheinungsbild des Forums auch so meine Probleme gehabt und habe sie z.T. noch.


    Ursprünglich sprangen die verwendeten Browser zwischen 2-3 sehr verschiedenen Darstellungen des Forums hin- und her, wenn man die Auflösung änderte (ist bei mir wegen verschiedener Monitore immer mal wieder nötig) oder wenn man die Vergrößerung (Zoom) im Browser änderte. Insbesondere gab es eine Darstellung, bei der Menü-Elemente (sowohl die in Textform, wie "Home", "The Dark Project" usw., als auch in Icon-Form, wie die Glocke für evtl. nicht gelesene Beiträge oder auch das zur Anmeldung zu klickende Icon) oben am Bildrand waren und eines, bei denen sie links und oben rechts zu finden waren. Einige der Icons sowie Bedienelemente waren auch je nach Darstellung völlig verschieden. Zum Anmelden z.B. musste ich in einer Darstellung oben rechts ein Icon wählen, was einen Kopf und Oberkörper darstellte, während ich in der anderen links ein Icon wählen musste, bei dem ein Pfeil aus einem Quadrat 'rauszeigte. Und manchmal musste ich erst noch die Icons "herbeizaubern", indem ich das "Hamburger-Menü" (drei horizontale Balken übereinander) aufklappte, und dann nach dem richtigen Icon suchen. Bisweilen gab es bei manchen Zoom-Größen auch Darstellungsfehler; so wurde manchmal die Schrift "Thief - The last GLASS" im Hintergrundbild mehrmals angezeigt, und je nach Auflösung auch unlesbar.


    Ich kann schon verstehen, dass einige Leute da Anmeldeschwierigkeiten hatten oder es recht unübersichtlich fanden. Meine Besuche hier haben sich seitdem auch verringert. Andererseits scheint es sich kürzlich verbessert zu haben; ob das an den Arbeiten der Admins liegt oder an Updates der verwendeten Browser, das kann ich nicht sagen.


    Wofür aber ist dieser seltsame Wechsel von Icons und Bedienelementen gut? Falls es sich um eine Darstellung für Handys und eine für den PC handelt, dann ist die Idee zweier Darstellungen sicher gut, die Automatik zum Umschalten aber sehr schlecht. Die schaltet dann ja auf ein und demselben Gerät im laufenden Betrieb um, obwohl sicher keiner das Kunststück hinkriegt, ein Handy während dessen Benutzung mal eben zu 'nem vollwertigen PC umzurüsten.^^



    Ich habe aber noch ein sehr störendes Problem. Ich empfange E-Mails unter Windows wie Linux mit Thunderbird. Die Mails von TTLG.DE werden mir dabei in hellgrauer Schrift auf weißem Grund angezeigt, was fast so sinnlos ist wie weiß auf weißem Grund. Nur durch Markieren des Texts kann ich die Mails lesen, ansonsten seh' ich nur die Bilder darin. Woran könnte das liegen, bzw. wie könnte ich das ggf. ändern?



    Ferner sind mir einige Absonderlichkeiten beim Editieren von Beiträgen aufgefallen. Jetzt gerade z.B. blieb Firefox 52.9.0 (ESR; unter Debian Linux 8.11) mehrmals beim Eingeben dieses Textes irgendwie "hängen", d.h. der Cursor verschwand, und meine Eingaben wurden nicht mehr angenommen. Erst, wenn ich mit der Maus irgendwo ins Fenster klickte, erschien der Cursor wieder, und ich konnte ihn an die richtige Stelle bewegen und weiter eingeben. Ist das noch anderen Leuten passiert?


    Beim Nachbearbeiten meiner Beiträge ist es außerdem früher vorgekommen, dass unter Linux die Auslastung des Rechners auf Maximum ging, und zwar durch den Firefox-Browser. Der hatte zu diesem Zeitpunkt nur die Aufgabe, den Cursor blinken zu lassen. Dafür 100% der CPU-Zeit zu verbraten, ist völlig unsinnig. Das Problem endete üblicherweise, wenn ich den Beitrag dann "abschickte". Es trat nicht auf, wenn ich einen Beitrag gerade neu schrieb, nur beim Nachbearbeiten eines bereits einmal geschriebenen Beitrags.


    Noch ein Schimpferchen zum Abschied: Wenn ich Zitate einsetzen lasse, kann ich sie manchmal nicht nachbearbeiten. Ich kann sie also nicht auf ein sinnvolles Maß zusammenkürzen. Daher muss ich da immer irgendwie von Hand 'rumfrickeln und den gewünschten Text mit Copy & Paste aus den Postings holen. Ähnlich läuft's manchmal mit Text von mir selber, den ich unter "Spoiler cover" verstecken will. Das ist sehr lästig, v.a. weil ich nicht 'rauskriege, wieso es manchmal passiert und manchmal nicht. Und sowieso interessiert sich die "Spoiler"-Funktion oben am Eingabefeld nur sehr rudimentär für das, was ich markiere, um es unter "Spoiler cover" zu verstecken. Die Funktion verwandelt dann nämlich grundsätzlich den ganzen Abschnitt in einen versteckten "Spoiler", nicht nur die von mir markierten Worte.


    Und jetzt gerade gibt es noch ein neues Problem: Wenn ich mit dem "Kursiv"-Knopf oben am Eingabefeld einen markierten Textteil kursiv machen will, wird der im Eingabefenster kursiv, aber in der Vorschau des Beitrags ist er dann nicht mehr kursiv. Nur, wenn ich mit (i) und (/i) (in eckigen Klammern) die Kursiv-Markierungen "von Hand" setze, funktioniert es richtig.


    Bin ich da der Einzige, der diese Eingabe-Probleme hat? Wenn nein, dann wäre ein wenig Nachforschen in diesen Dingen schon recht hilfreich für die von solchen Sachen geplagten Nutzer.

  • Das eine Teilproblem liest sich so, als würde der Browser zwischen Mobil- und Desktop-Darstellung hin- und herwechseln. Ist aber normal - den gleichen Effekt kann man erzielen, wenn man das Browser-Fenster schmal genug verkleinert. Nennt sich responsives Design. Dein Szenario trifft auf den Großteil der Nutzer nicht so, würde ich mal vermuten. Aber ich empfehle dir, installiere ein Erweiterung für Firefox, wo du den UserAgent manuell auf Desktop setzen kannst. Das müsste dem entgegen kommen.


    Zitat

    Wofür aber ist dieser seltsame Wechsel von Icons und Bedienelementen gut? Falls es sich um eine Darstellung für Handys und eine für den PC handelt, dann ist die Idee zweier Darstellungen sicher gut, die Automatik zum Umschalten aber sehr schlecht. Die schaltet dann ja auf ein und demselben Gerät im laufenden Betrieb um, obwohl sicher keiner das Kunststück hinkriegt, ein Handy während dessen Benutzung mal eben zu 'nem vollwertigen PC umzurüsten.^^

    Außer Desktop und Handy gibt es noch eine dritte Gruppe: Tablets oder Tablet-Rechner. Benutzt man die im Portrait-Modus, verhält sich die Darstellung wie auf Handy. Hält man die Dinger hingegen quer oder benutzt sie mit Tastatur wie als einen Laptop, dann wird "live" auf die Desktop-Darstellung gewechselt. Dies hat schon seine Richtigkeit.


    Zu den anderen Kleinigkeiten: Ich selber habe unter Windows 10, Chrome oder Edge keine nennenswerten Probleme. Ich müsste mal schauen, ob ich oben genannte Fälle reproduzieren kann. Aber Firefox 52, von wann ist der eigentlich nochmal? Und ist das die letzte ESR oder gibt es auch neuere? :/:/


    Zumal ich teilweise Schwierigkeiten habe, einige Sachverhalte zu verstehen. Da würde ich mir Bilder von dir wünschen.


    Und jetzt gerade gibt es noch ein neues Problem: Wenn ich mit dem "Kursiv"-Knopf oben am Eingabefeld einen markierten Textteil kursiv machen will, wird der im Eingabefenster kursiv, aber in der Vorschau des Beitrags ist er dann nicht mehr kursiv. Nur, wenn ich mit (i) und (/i) (in eckigen Klammern) die Kursiv-Markierungen "von Hand" setze, funktioniert es richtig.

    Das kann ich auf meinem Browser nicht bestätigen. Da funktioniert die Vorschau einwandfrei. Das gleiche gilt das Verstecken von Text in Spoilern und das dortige nachträgliche Bearbeiten.

    Edit 2018-08-09 19:40: Gerade gesehen, dass es ESR 60 gibt. Warum verwendest du nicht diese?


    Edit 2018-08-09 19:53: Einen zweiten Testlauf mit Portable Firefox ESR 52 gemacht. Auch dort keine Probleme.


    Edit 2018-08-10 12:05: Einen dritten Testlauf mit Debian 8.11 unter VirtualBox und Firefox ESR 52 gemacht. Nach wie vor keine Probleme.