Alte Spielstände aus 1999 laden

  • Von meinem alten Rechner habe ich mir meine Original-Spielstände von T1 aus 1999 gesichert.

    Diese wollte ich nun in meiner aktuellen T1-Installation (New Dark 1.23) auf meinem Rechner laden. Dazu habe die alten sav-Dateien mit den dazugehörigen bnd-Dateien in den Ornder SAVES kopiert.

    Wenn ich nun das Spiel starte werden mir die alten Speicherstände im Menü angezeigt. Wähle ich einen Speicherstand einer Mission aus, wird allerdings nicht der Speicherstand im Spiel geladen, stattdessen beginnt die Mission ganz von vorn mit der jeweiligen Cutscene. ?(

    Weiß jemand von euch was ich falsch gemacht habe?


    Edit: Durch etwas Probieren hab ich herausgefunden, dass es wohl an der gepatchten Thief.exe liegt. Mit der Original-Thief.exe werden die Spielstände korrekt geladen, das Spiel ist dann allerdings nicht spielbar... Gibt es irgend eine Möglichkeit die alten Savegames mit NewDark zu laden?

  • Stimmt, daran liegt es wahrscheinlich!

    Habe das Originalspiel nun in seiner ursprünglichsten Version auf meinem Rechner unter Win7 neu installiert. Die alten Savegames werden nun wie gewünscht geladen. Allerdings sieht das Spiel ohne TFix ziemlich schlimm aus (Auflösung, Farben, zu schnelle Geschwindigkeit beim Laufen...).

    Gibt es noch irgendwo einen alten Patch, der das Spiel auf neuen Rechnern lauffähig macht und ohne NewDark auskommt?

  • Schade, trotzdem danke fürs Ausprobieren!

    Ich habe nun probiert, die Spielstände mit T1 ohne ND zu laden. Ich habe noch eine alte T1-Installation auf meiner Festplatte, bei der die thief.exe mit ddfix gepatcht war. Das klappt leider auch nicht. Gab es denn vor NewDark und ddfix noch andere Patches, das Spiel auf moderneren Rechnern irgendwie spielbar zu machen?

    Ich würde die alten Spielstände irgendwie gern nochmal anspielen können.

  • Was klappt denn nicht mit ddfix? Das Multicore-Problem? Ich starte das Originalspiel oft.

    Starte das Spiel, gehe gleich in den Taskmanager und adressiere der Thief.exe einen einzelnen Kern, dann geht es.

    Oder du installierst Tfix ohne die NewDark-Option (s. Tfix Menu). Dann bekommst du ddfix installiert.

  • Nein, das Spiel lässt sich mit ddfix starten, was nicht klappt ist das Laden der alten Speicherstände - genau wie bei NewDark. Auch bei ddfix wird ja die thief.exe gepatcht. Scheinbar lassen sich die saves nur laden, wenn die thief.exe unversehrt bleibt.

    Wenn ich das Originalspiel starte und der thief.exe nur einen Core zuweise bleibt das Spiel trotzdem hängen.

  • Du mußt die Speicherstände in der Version starten, in der sie abgespeichert wurden.

    Es gab für T1

    -1.14 (ungepatcht)

    -1.33 (gepatcht)

    TG

    -1.37

    ddfix macht da keinen Unterschied in der Produktversion.


    Wenn das Spiel hängen bleibt, kann das auch an der install.cfg liegen. Besser relative Pfade angeben. Tfix wird das bei Bedarf machen.


    Edit: Ich habe die Speicherstände jetzt mal in T1/1.33 ohne irgendwas, auch ohne Tfix geladen - mit ein Kern zugeordnet. Die Speicherstände fangen am Anfang der Missionen an.

    Mit T1/1.14 habe ich es nicht probiert.

  • Da meine alten Saves unter Version 1.14 definitiv geladen werden, will ich nun Thief 1 mit Version 1.14 auf meinem Rechner zum Laufen bringen. Habe das Originalspiel installiert. Dann die thief.exe mit ddfix manuell gepacht. Die install.cfg habe ich durch relative Pfade ersetzt:

    cd_path .\

    install_path .\

    language german

    resname_base .\

    load_path .\

    script_module_path .\

    movie_path .\movies

    Das Spiel starten mit dem Menü in der gewünschen Auflösung. Mittels Taskmanager überprüft, dass Thief.exe-Prozess nur unter einem Kern läuft. Dann zurück zum Spiel: Unter Saves sehe ich meine alten Spielstände, diese werden auch geladen. Danach crasht das Spiel:

    Problemsignatur:

    Problemereignisname: APPCRASH

    Anwendungsname: thief.exe

    Anwendungsversion: 1.9.0.0

    Anwendungszeitstempel: 364a3ba7

    Fehlermodulname: thief.exe

    Fehlermodulversion: 1.9.0.0

    Fehlermodulzeitstempel: 364a3ba7

    Ausnahmecode: c0000005

    Ausnahmeoffset: 0014344a

    Betriebsystemversion: 6.1.7601.2.1.0.256.48

    Gebietsschema-ID: 1031

    Zusatzinformation 1: e098

    Zusatzinformation 2: e098f84aa18614de977d6849d087f375

    Zusatzinformation 3: a126

    Zusatzinformation 4: a126146b2f921222d16280cb69d53a1a

    Lesen Sie unsere Datenschutzbestimmungen online:

    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

    Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:

    C:\windows\system32\de-DE\erofflps.txt

    Der gleiche Fehler passiert, wenn ich das Spiel mit der Einführungsmission starten will.

    Was mache ich nur falsch? :/

  • Woher weißt du, dass die Spielstände in 1.14 laufen?

    Ganz einfach, weil die Spielstände im Originalspiel 1.14 bei mir ganz normal geladen werden, d.h. die Missionen starten dann nicht vom Anfang sondern wie gewünscht an der früheren Speicherstelle der Mission. Das klappt bei mir allerings nur, wenn ich das Originalspiel ohne Patches in 1.14 starte und einem Kern zuweise. Das Problem an der Sache ist dann aber, dass die Missionen unspielbar sind (betrifft die Auflösung, Texturen und Laufgeschwindigkeit). Außerdem kommt es zu sofortigen Abbrüchen, sobald ich in das Optionen-Menü wechsle und z.B. die Grafikeinstellungen verändern möchte.

    Mit ddfix bekomme ich das Spiel unter 1.14 gar nicht zum Laufen (siehe mein letzter Post oben). Scheinbar ist ddfix so konfiguriert worden, dass man mindestens Version 1.33 benötigt. Unter 1.33 bekomme ich das Spiel mittels ddfix auf meinem Rechner nämlich ohne Probleme zum Laufen. Allerdings werden da meine alten Spielstände nicht mehr geladen, was mir dann auch nicht wirklich hilft... Es ist wie verhext! ||

    Ich muss mich wahrscheinlich damit abfinden, das es nicht geht. Oder ich kaufe mir bei Ebay einen 20 jahre alten gebrauchten Rechner mit einem Prozessorkern, einer alten Grafikkarte, einem 4:3 15-Zoll Monitor und Windows 95... Hat jemand von euch zufälligerweise noch so ein Gerät nutzloserweise herumstehen? 8o 

  • Mit 1.14 kannst du halt nur einen Kern zuweisen.

    -manuell oder so http://www.thief-thecircle.com/guides/hyperthreading/

    -oder ein Hilfsprogramm nehmen, wie FlipTIB

    http://darkfate.org/?show=files/misc_stuff/FlipTIB_v1.0.zip

    -Zur Auflösung: Das ist natürlich ein Problem. Du kannst nur versuchen eine 4:3 Auflösung zu finden, die passt. Widescreen ist nicht. Vielleicht hilft es, die Desktop-Auflösung temporär zu ändern.

    Vielleicht hilft der D3D-Windower weiter, der ist immer zu was gut

    https://community.pcgamingwiki…/733-d3dwindower-english/

    -Zu schnell laufen: Beschäftige die Grafikkarte

    Zitat


    Aktiviere v-sync. Achte darauf, dass die refresh rate bei 60Hz liegt. Versuche ebenfalls auf full antialiasing zu gehen.

  • Danke für die Links!

    Das Hyperthreading-Problem habe ich Dank deines ersten Links nun prima gelöst. :)

    Außerdem klappt es mit dem Fenstermodus mittels D3D Windower hervorragend! Damit kann ich ja tatsächlich jede beliebige Auflösung einstellen! :thumbup:

    Frage in diesem Zusammenhang: Ich möchte gern die maximale Höhe meines Monitors ausnutzen. Im Window-Modus verdeckt allerdings die Taskleiste den untersten Bereich. Kann ich es auch so einstellen, dass das Spiel immer im Vordergrund läuft, dass also die Taskleiste verdeckt wird?

    Eine zweite kleinere Sache noch, die mich stört... Die Videos (Intro, Cutsequenzen...) werden seltsamerweise nicht abgespielt. Ich habe alle Videos mit auf die Festplatte gepackt (D:\Der Meisterdieb\MOVIES). Unter der install.cfg habe ich die relativen Pfade sind eingestellt (s.o.). Original-CD ist im Laufwerk (muss ich beim Start sowieso einlegen). Die Codecs habe ich installiert...

    Was mich eben wundert: Bei allen anderen Thief-Installationen auf meinem PC laufen die Videos einwandfrei. :/

    Was könnte ich hier noch probieren?

  • -Wegen Movies: ddfix registriert die Codecs automatisch, ND bringt alles von Haus aus mit. Im FAQ wird dargestellt was zu tun ist, um die Codecs zum Laufen zu bringen.

    -Gibts im D3D-Windower nicht die Option, den Inhalt im Vordergrund darzustellen? Ich kann mich gerade nicht erinnern. Meist ist es F11.

  • Dann mußt du die Taskleiste ausblenden. Rechtsklick drauf-->Taskleiste im Desktopmodus automatisch ausblenden (Win 10)
    Oder unter Win7/8 in die Eigenschaften der Taskleiste gehen.


    Wenn du mit der Maus drüberstreichst, sollte sie wieder da sein.

  • Habe die Taskleiste einfach an den rechten Bildschirmrand geschoben, aber so klappts natürlich auch.

    Zu den Videos: Ich habe die Codecs nochmal neu installiert. Wenn ich die thief.exe als Administrator starte, werde die Videos tadellos abgespielt - soweit so gut.

    Allerdings gibt es ein nun ein neues Problem mit D3D Windower: Wenn ich das Spiel im Fenstermodus via D3DWindower starte, höre ich nur den Ton vom Video. Stattdessen sehe weiterhin das Startmenü vom Spiel und ich kann nichts mehr machen. :rolleyes: