T2fix/TafferPatcher für T2

  • Eine wie ich meine ganz wunderbare Sache hat sich DJ Riff ausgedacht: Einen multiplen Patch für Thief 2, den sog. „TafferPatcher“, in dem die gängigen Patches für T2 untergebracht sind. Das wichtigste ist der 1.18-, auf Wunsch 1.25 (Newdark) Patch, ddfix, Scripte, zusätzliche Modifikationen wie Enhancement Pack und vieles mehr. TafferPatcher bringt einen kompletten Installer mit, mit dem man das gesamte Spiel installieren kann. Während der Installation kann man selbst entscheiden, welche der Verbesserungen installiert werden soll.

    Um eine bestehende Installation auf den neuersten Stand zu bringen, einfach Tafferpatcher ausführen und den Pfad zur Installation zuweisen.


    Bitte für die DromEd-Installation beachten: Man sollte in der T2-Version, die für die Arbeit mit Dromed bestimmt ist, keine weiteren Zusatzpacks, die im Tafferpatcher integriert sind, installieren. Sonst kommt es zu Überschneidungen mit den Originalressourcen.Die neueren Tafferpatcher-Versionen installieren auch das DromEd-Toolkit.


    T2Fix 1.27d

    https://drive.google.com/file/…hNRoeYXkdAM7idP4Pe_V/view

    T2Fix 1.27c

    https://drive.google.com/open?…qNI2-6_ntMd3TZl5FFxS57Fdx

    T2Fix 1.27a mit NewDark 1.27 und dmls für Fanmissionen bis einschließlich 2005

    https://drive.google.com/open?…9xHazanNIqo5L14jynl85czcx

    T2Fix 1.27 mit NewDark

    https://drive.google.com/open?…Tbzna_lLyjLombYoOLjvehJxA

    T2Fix 1.26 mit NewDark und mehr

    https://drive.google.com/open?…q9BwOT25WypRH4kmoo-pvou4X


    Download:
    Tafferpatcher 2.18 mit NewDark 1.25


    Tafferpatcher 2.17 mit NewDark 1.24 und NVScript 1.24



    Alte Versionen



    Scripts (tnh/NV/Public Scripts) für FMs werden seit 2.06 installiert. Man kann sie ansonsten hier herunterladen.

  • Kann es sein, dass der Tafferpatcher zwar eine ältere DDFIX- Version verwendet, aber da man im Setup einstellen kann, dass der Nebel in Win 7 funktionieren soll, dies irrelevant ist?

  • DJRiff verwendete nach eigenen Angaben den Nebel-Fix von SIO2, sprich ddfix 1.4xx..


    Edit: Genauer ddfix version 1.4.4


    Diese Version kann man mit der gewünschten Version überschreiben (bzw. in solchen Fällen mach ich immer ein Backup der alten Version, funktionierenden Version, bevor ich die Neue probiere).

  • DJRiff hat den Tafferpatcher nun etwas "erneuert", ddfix 1.5.5 ist nun integriert, außerdem benutzt TP nun den Multicore-Fix Algorithmus von FlipTIB.
    Zudem wird nun angezeigt, welche Komponenten schon installiert sind.



    Habs eben mal ausprobiert, es funktioniert. Allerdings haben NVIDIA-Karten ein Problem. In den 3D-Einstellungen muß der Reiter


    Maximale Anzahl der vorgerenderten Einzelbilder=0



    ausgewählt werden, sonst bleibt das Startmenü hängen.

  • DJRiff hat eine neue Version des Tafferpatchers veröffentlicht, er unterstützt nun ddfix 1.5.11, 1.5.5 und 1.1.1. Dazu kamen verschiedene Modifikationen, usw. (s.u.)



    Quote

    Compatibility issues
    If you used previous version of TafferPatcher, please remove the mission fixes (loot location, dialogs etc.) using that old version or move mission files from Tafferpatcher\Backup\miss*fix\* to parent folder Tafferpatcher\Backup\. Otherwise you won't be able to uninstall them later.
    Any other fixes are backward-compatible.



    Eine Bemerkung von mir:
    ddfix 1.5.5 ist im Zweifel die bessere und problemlosere Wahl, damit laufen auch die Erweiterungsmodifikationen.


    Und weil DJRiff gerade in Fahrt ist: Version 0.93




    Version 0.94

    Quote

    — Fixed wrong position of Preset List, which caused it to overlap the component description text. (for good this time)
    — In ddfix.ini editor, selecting a checkbox item (the text) no longer changes the checkbox state. You need to click a checkbox itself to do it. I'm using user32.dll function for that, so extensive testing needed on Windows x64 systems.
    — Improved performance of ddfix.ini editor when saving ddfix.ini file.
    — Some standard installer messages were changed to represent performed actions better.

  • ich habe vor kurzem dem Tafferpatcher auf meine Originalinstallation installiert und alles läuft bisher tadellos ausser
    dass ich nicht die Auflösung im Thief2 Menue verstellen kann. Es gibt nur 2 Auswahlmöglichkeiten, entweder
    640 x 480 x 16 oder
    800 x 600 x 16


    Beides sieht irgendwie nicht so aus wie ich es früher hatte, damals nutze ich immer die höchste Auflösung (irgendwas mit 1000).
    Bei der Installation fragte mich das Patchprogramm nach meiner Auflösung, dort habe ich nichts hingeschrieben, da ich sie nicht wusste.

  • Mit ddfix (und das ist in Tafferpatcher integriert) kannst du die Auflösung nicht mehr im Menü des Spiels einstellen. Die (gewünschte) Auflösung mußt du erstmal kennen - im Zweifel nimmst du die Auflösung des Desktops -, dann hast du die Optionen:


    1. Im Tafferpatcher-Setup die Einstellung zu treffen
    2. Nachträglich sowohl in der cam.cfg und bei einer älteren ddfix-Version als 1.5.8. auch in der ddfix.ini einzustellen.

  • hmm, ich habs nun mit verschiedenen Einstellungen probiert, auch mit der Auflösung, die mein Desktop verwendet, leider ohne Erfolg. Das Spiel stürzt beim laden immer ab.


    Welche Auflösung hast du in die cam.cfg und in die Ddfix.ini eingetragen?

  • Inwischen ist Version 0.96 erschienen, die auch deutsche Sprachunterstützung im Menü bietet



  • Version 0.98; weitere Bugfixes. Die deutsche Sprachunterstützung im Menü (dank Gnartsch) wurde weiter verfeinert.
    Frühere 0.9er-Versionen sind nicht mehr verfügbar (es sei denn, jemand fordert sie an).



    Version 1.00. Keine wesentlichen Änderungen

  • Wegen des SAT1-1.18 Sonderpatchs? Das habe ich nie probiert, aber wenn ich mich recht entsinne, funktioniert der Premier-Patch, der ja in TP enthalten ist, auch damit. Aber da du schon Interesse daran zeigst, bekommst du eine Forschungsaufgabe: Kopiere doch mal bitte eine solche SAT1-Version irgendwo hin (z. B. auf eine andere Partition/anderes Verzeichnis, passe in der darkinstall.cfg die Pfade an und lasse den Tafferpatcher über diese Kopie drüberlaufen.

  • Ich konnte es nun auch erfolgreich installieren und testen.
    Ich habe die Original Thief 2 version installiert, deutsch. Ich brauchte nirgendwo einen Ordner von Englisch in German umzubenennen.

    Schau doch mal im Thief Chat vorbei....
    Und wenn der nicht funzt, dann nimm den Ausweichchat ...

  • Quote

    Original von Xrayalpha Ich brauchte nirgendwo einen Ordner von Englisch in German umzubenennen.


    Das gilt eigentlich nur für die Urversion 0.6 und steht dennoch zur Sicherheit da. Auch der Tafferpatcher ist nur ein Programm, das nicht immer alles macht.

  • Habe nun auch mal wieder T2 installiert und dann das ddfix. Da kam es dann aber zu Abstürzen. Dann dachte ich, ok, machste mal den TafferPatcher drüber - wieder nix. Alles deinstalliert, dann gleich mit TafferPatcher komplett neu aufgezogen - und funktioniert bestens. Bei ddfix habe ich die 1.5.5 genommen. Da ich auch die Sat1 Version habe, kann ich hier nun auch bestätigen, dass es einwandfrei funktioniert.


    In Zukunft werde ich wohl nur noch den TafferPatcher einsetzen, sofern er keine Probleme bereitet. :)